aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/dix/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xorg-server/dix/Makefile.am')
-rw-r--r--xorg-server/dix/Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/xorg-server/dix/Makefile.am b/xorg-server/dix/Makefile.am
index 4c2395d82..13e5dedd7 100644
--- a/xorg-server/dix/Makefile.am
+++ b/xorg-server/dix/Makefile.am
@@ -1,8 +1,9 @@
-noinst_LTLIBRARIES = libdix.la
+noinst_LTLIBRARIES = libdix.la libmain.la
-AM_CFLAGS = $(DIX_CFLAGS) \
- -DVENDOR_NAME=\""@VENDOR_NAME@"\" \
- -DVENDOR_RELEASE="@VENDOR_RELEASE@"
+AM_CFLAGS = $(DIX_CFLAGS)
+
+libmain_la_SOURCES = \
+ main.c
libdix_la_SOURCES = \
atom.c \
@@ -17,6 +18,7 @@ libdix_la_SOURCES = \
enterleave.c \
enterleave.h \
events.c \
+ eventconvert.c \
extension.c \
ffs.c \
gc.c \
@@ -25,7 +27,7 @@ libdix_la_SOURCES = \
glyphcurs.c \
grabs.c \
initatoms.c \
- main.c \
+ inpututils.c \
pixmap.c \
privates.c \
property.c \