aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/exa/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xorg-server/exa/Makefile.am')
-rw-r--r--xorg-server/exa/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/xorg-server/exa/Makefile.am b/xorg-server/exa/Makefile.am
new file mode 100644
index 000000000..e2f7ed302
--- /dev/null
+++ b/xorg-server/exa/Makefile.am
@@ -0,0 +1,26 @@
+noinst_LTLIBRARIES = libexa.la
+
+# Override these since EXA doesn't need them and the needed files aren't
+# built (in hw/xfree86/os-support/solaris) until after EXA is built
+SOLARIS_ASM_CFLAGS=""
+
+if XORG
+sdk_HEADERS = exa.h
+endif
+
+INCLUDES = \
+ $(XORG_INCS) \
+ -I$(srcdir)/../miext/cw
+
+AM_CFLAGS = $(XORG_CFLAGS) $(DIX_CFLAGS)
+
+libexa_la_SOURCES = \
+ exa.c \
+ exa.h \
+ exa_accel.c \
+ exa_migration.c \
+ exa_offscreen.c \
+ exa_render.c \
+ exa_priv.h \
+ exa_unaccel.c
+