aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/fonts.src/font-util/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xorg-server/fonts.src/font-util/Makefile.am')
-rw-r--r--xorg-server/fonts.src/font-util/Makefile.am22
1 files changed, 14 insertions, 8 deletions
diff --git a/xorg-server/fonts.src/font-util/Makefile.am b/xorg-server/fonts.src/font-util/Makefile.am
index d9d581bdd..fe23e3446 100644
--- a/xorg-server/fonts.src/font-util/Makefile.am
+++ b/xorg-server/fonts.src/font-util/Makefile.am
@@ -19,14 +19,12 @@
# NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN
# CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
-bin_PROGRAMS = ucs2any
-bin_SCRIPTS = bdftruncate
+bin_PROGRAMS = bdftruncate ucs2any
-ucs2any_SOURCES = ucs2any.c
+AM_CFLAGS = $(CWARNFLAGS)
-bdftruncate: $(top_srcdir)/bdftruncate.pl
- @rm -f $@
- cp $(top_srcdir)/bdftruncate.pl $@
+ucs2any_SOURCES = ucs2any.c
+bdftruncate_SOURCES = bdftruncate.c
aclocaldir = $(datadir)/aclocal
aclocal_DATA = fontutil.m4
@@ -62,8 +60,6 @@ CLEANFILES = bdftruncate $(appman_DATA)
EXTRA_DIST = $(mapfiles_DATA) \
$(appman_PRE) \
- autogen.sh \
- bdftruncate.pl \
fontutil.pc.in \
$(aclocal_DATA)
@@ -81,3 +77,13 @@ SUFFIXES = .$(APP_MAN_SUFFIX) .man
.man.$(APP_MAN_SUFFIX):
sed $(MAN_SUBSTS) < $< > $@
+
+EXTRA_DIST += ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ $(CHANGELOG_CMD)
+
+dist-hook: ChangeLog