aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/glx/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xorg-server/glx/Makefile.am')
-rw-r--r--xorg-server/glx/Makefile.am21
1 files changed, 11 insertions, 10 deletions
diff --git a/xorg-server/glx/Makefile.am b/xorg-server/glx/Makefile.am
index 0214295ea..6facc2011 100644
--- a/xorg-server/glx/Makefile.am
+++ b/xorg-server/glx/Makefile.am
@@ -22,9 +22,12 @@ INCLUDES = \
-I$(top_srcdir)/hw/xfree86/os-support/bus \
-I$(top_srcdir)/hw/xfree86/common \
-I$(top_srcdir)/hw/xfree86/dri \
- -I$(top_srcdir)/hw/xfree86/dri2 \
-I$(top_srcdir)/mi
+if DRI2_AIGLX
+INCLUDES += -I$(top_srcdir)/hw/xfree86/dri2
+endif
+
glapi_sources = \
indirect_dispatch.c \
indirect_dispatch.h \
@@ -41,21 +44,19 @@ glapi_sources = \
glapi.c \
glapi.h \
glapioffsets.h \
+ glprocs.h \
glthread.c \
- glthread.h \
- glprocs.h
-
-if DRI2
-GLXDRI_SOURCE = glxdri2.c
-endif
+ glthread.h
libglxdri_la_SOURCES = \
glxdri.c \
- $(GLXDRI2_SOURCE) \
- glxdricommon.h \
extension_string.c \
extension_string.h
+if DRI2_AIGLX
+libglxdri_la_SOURCES += glxdri2.c
+endif
+
libglx_la_SOURCES = \
$(indirect_sources) \
$(glapi_sources) \
@@ -74,10 +75,10 @@ libglx_la_SOURCES = \
glxext.h \
glxdriswrast.c \
glxdricommon.c \
+ glxdricommon.h \
glxscreens.c \
glxscreens.h \
glxserver.h \
- glxutil.c \
glxutil.h \
render2.c \
render2swap.c \