aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/hw/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xorg-server/hw/Makefile.am')
-rw-r--r--xorg-server/hw/Makefile.am51
1 files changed, 51 insertions, 0 deletions
diff --git a/xorg-server/hw/Makefile.am b/xorg-server/hw/Makefile.am
new file mode 100644
index 000000000..c2b9571b9
--- /dev/null
+++ b/xorg-server/hw/Makefile.am
@@ -0,0 +1,51 @@
+if DMX
+DMX_SUBDIRS = dmx
+endif
+
+if XORG
+XORG_SUBDIRS = xfree86
+endif
+
+if XVFB
+XVFB_SUBDIRS = vfb
+endif
+
+if XNEST
+XNEST_SUBDIRS = xnest
+endif
+
+if XWIN
+XWIN_SUBDIRS = xwin
+endif
+
+if XGL
+XGL_SUBDIRS = xgl
+endif
+
+if KDRIVE
+KDRIVE_SUBDIRS = kdrive
+endif
+
+if XPRINT
+XPRINT_SUBDIRS = xprint
+endif
+
+if XQUARTZ
+XQUARTZ_SUBDIRS = xquartz
+endif
+
+SUBDIRS = \
+ $(XORG_SUBDIRS) \
+ $(XGL_SUBDIRS) \
+ $(XWIN_SUBDIRS) \
+ $(XVFB_SUBDIRS) \
+ $(XNEST_SUBDIRS) \
+ $(DMX_SUBDIRS) \
+ $(KDRIVE_SUBDIRS) \
+ $(XQUARTZ_SUBDIRS) \
+ $(XPRINT_SUBDIRS)
+
+DIST_SUBDIRS = dmx xfree86 vfb xnest xwin xquartz kdrive xgl xprint
+
+relink:
+ for i in $(SUBDIRS) ; do $(MAKE) -C $$i relink ; done