aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/hw/dmx/doxygen/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xorg-server/hw/dmx/doxygen/Makefile.am')
-rw-r--r--xorg-server/hw/dmx/doxygen/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/xorg-server/hw/dmx/doxygen/Makefile.am b/xorg-server/hw/dmx/doxygen/Makefile.am
new file mode 100644
index 000000000..fe159df5c
--- /dev/null
+++ b/xorg-server/hw/dmx/doxygen/Makefile.am
@@ -0,0 +1,36 @@
+# Copyright 2005 Red Hat, Inc.
+#
+# Permission to use, copy, modify, distribute, and sell this software
+# and its documentation for any purpose is hereby granted without
+# fee, provided that the above copyright notice appear in all copies
+# and that both that copyright notice and this permission notice
+# appear in supporting documentation, and that the name of Red Hat
+# not be used in advertising or publicity pertaining to distribution
+# of the software without specific, written prior permission. Red
+# Hat makes no representations about the suitability of this software
+# for any purpose. It is provided "as is" without express or implied
+# warranty.
+#
+# RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN
+# NO EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS
+# OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT,
+# NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN
+# CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+
+if ENABLE_DEVEL_DOCS
+if HAVE_DOXYGEN
+
+# Developers documentation is not installed
+noinst_DATA = html/index.html
+dist_noinst_DATA = doxygen.conf.in footer.html
+
+html/index.html:
+ $(AM_V_GEN)$(DOXYGEN) doxygen.conf
+
+clean-local:
+ $(AM_V_at)rm -fr html/
+
+endif HAVE_DOXYGEN
+endif ENABLE_DEVEL_DOCS