aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/hw/kdrive/ephyr/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xorg-server/hw/kdrive/ephyr/Makefile.am')
-rw-r--r--xorg-server/hw/kdrive/ephyr/Makefile.am22
1 files changed, 11 insertions, 11 deletions
diff --git a/xorg-server/hw/kdrive/ephyr/Makefile.am b/xorg-server/hw/kdrive/ephyr/Makefile.am
index 9380e4d0a..ec6f4450a 100644
--- a/xorg-server/hw/kdrive/ephyr/Makefile.am
+++ b/xorg-server/hw/kdrive/ephyr/Makefile.am
@@ -8,14 +8,14 @@ INCLUDES = \
-I$(top_srcdir)/exa
if XV
-LIBXEPHYR_HOSTXV=libxephyr-hostxv.a
+LIBXEPHYR_HOSTXV=libxephyr-hostxv.la
endif
if DRI
-LIBXEPHYR_HOSTDRI=libxephyr-hostdri.a
+LIBXEPHYR_HOSTDRI=libxephyr-hostdri.la
endif
-noinst_LIBRARIES = libxephyr-hostx.a $(LIBXEPHYR_HOSTXV) $(LIBXEPHYR_HOSTDRI) libxephyr.a
+noinst_LTLIBRARIES = libxephyr-hostx.la $(LIBXEPHYR_HOSTXV) $(LIBXEPHYR_HOSTDRI) libxephyr.la
bin_PROGRAMS = Xephyr
@@ -47,24 +47,24 @@ XEPHYR_SRCS = \
ephyr_draw.c \
os.c
-libxephyr_hostx_a_SOURCES = $(HOSTX_SRCS)
+libxephyr_hostx_la_SOURCES = $(HOSTX_SRCS)
if XV
-libxephyr_hostxv_a_SOURCES = $(HOSTVIDEO_SRCS)
+libxephyr_hostxv_la_SOURCES = $(HOSTVIDEO_SRCS)
endif
if DRI
-libxephyr_hostdri_a_SOURCES = $(HOSTDRI_SRCS)
+libxephyr_hostdri_la_SOURCES = $(HOSTDRI_SRCS)
endif
-libxephyr_a_SOURCES = $(XEPHYR_SRCS)
+libxephyr_la_SOURCES = $(XEPHYR_SRCS)
Xephyr_SOURCES = \
ephyrinit.c
Xephyr_LDADD = \
- libxephyr.a \
- libxephyr-hostx.a \
+ libxephyr.la \
+ libxephyr-hostx.la \
$(LIBXEPHYR_HOSTXV) \
$(LIBXEPHYR_HOSTDRI) \
$(top_builddir)/exa/libexa.la \
@@ -72,8 +72,8 @@ Xephyr_LDADD = \
@XEPHYR_LIBS@
Xephyr_DEPENDENCIES = \
- libxephyr.a \
- libxephyr-hostx.a \
+ libxephyr.la \
+ libxephyr-hostx.la \
$(LIBXEPHYR_HOSTXV) \
$(LIBXEPHYR_HOSTDRI) \
@KDRIVE_LOCAL_LIBS@