aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/hw/kdrive/fake/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xorg-server/hw/kdrive/fake/Makefile.am')
-rw-r--r--xorg-server/hw/kdrive/fake/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/xorg-server/hw/kdrive/fake/Makefile.am b/xorg-server/hw/kdrive/fake/Makefile.am
index 76ed9fc8b..8b93e9e2f 100644
--- a/xorg-server/hw/kdrive/fake/Makefile.am
+++ b/xorg-server/hw/kdrive/fake/Makefile.am
@@ -2,11 +2,11 @@ INCLUDES = \
@KDRIVE_INCS@ \
@KDRIVE_CFLAGS@
-noinst_LIBRARIES = libfake.a
+noinst_LTLIBRARIES = libfake.la
bin_PROGRAMS = Xfake
-libfake_a_SOURCES = \
+libfake_la_SOURCES = \
fake.c \
kbd.c \
os.c \
@@ -17,14 +17,14 @@ Xfake_SOURCES = \
fakeinit.c
Xfake_LDADD = \
- libfake.a \
+ libfake.la \
@KDRIVE_LIBS@ \
@XSERVER_LIBS@
-Xfake_LDFLAGS = $(LD_EXPORT_SYMBOLS_FLAG)
+Xfake_LDFLAGS = $(LD_EXPORT_SYMBOLS_FLAG) -Wl,-undefined=InitExtensions
Xfake_DEPENDENCIES = \
- libfake.a \
+ libfake.la \
@KDRIVE_LOCAL_LIBS@
relink: