aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/hw/kdrive/linux/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xorg-server/hw/kdrive/linux/Makefile.am')
-rw-r--r--xorg-server/hw/kdrive/linux/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/xorg-server/hw/kdrive/linux/Makefile.am b/xorg-server/hw/kdrive/linux/Makefile.am
new file mode 100644
index 000000000..e13d08312
--- /dev/null
+++ b/xorg-server/hw/kdrive/linux/Makefile.am
@@ -0,0 +1,34 @@
+INCLUDES = \
+ @KDRIVE_INCS@ \
+ @KDRIVE_CFLAGS@
+
+AM_CFLAGS = -DHAVE_DIX_CONFIG_H
+
+noinst_LIBRARIES = liblinux.a
+
+if TSLIB
+TSLIB_C = tslib.c
+endif
+
+if H3600_TS
+TS_C = ts.c
+endif
+
+if KDRIVE_HW
+KDRIVE_HW_SOURCES = \
+ agp.c \
+ agp.h \
+ evdev.c \
+ keyboard.c \
+ linux.c
+endif
+
+liblinux_a_SOURCES = \
+ bus.c \
+ klinux.h \
+ mouse.c \
+ ms.c \
+ ps2.c \
+ $(KDRIVE_HW_SOURCES) \
+ $(TSLIB_C) \
+ $(TS_C)