aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/hw/kdrive/smi/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xorg-server/hw/kdrive/smi/Makefile.am')
-rw-r--r--xorg-server/hw/kdrive/smi/Makefile.am41
1 files changed, 0 insertions, 41 deletions
diff --git a/xorg-server/hw/kdrive/smi/Makefile.am b/xorg-server/hw/kdrive/smi/Makefile.am
deleted file mode 100644
index bd7077c56..000000000
--- a/xorg-server/hw/kdrive/smi/Makefile.am
+++ /dev/null
@@ -1,41 +0,0 @@
-INCLUDES = \
- -I$(top_srcdir)/hw/kdrive/fbdev \
- -I$(top_srcdir)/hw/kdrive/vesa \
- @KDRIVE_INCS@ \
- @KDRIVE_CFLAGS@
-
-bin_PROGRAMS = Xsmi
-
-noinst_LIBRARIES = libsmi.a
-
-# smivideo.c # not ready yet
-
-libsmi_a_SOURCES = \
- smi.c \
- smi.h \
- smidraw.c \
- smidraw.h
-
-Xsmi_SOURCES = \
- smistub.c
-
-SMI_LIBS = \
- libsmi.a \
- $(top_builddir)/hw/kdrive/fbdev/libfbdev.a \
- $(top_builddir)/hw/kdrive/vesa/libvesa.a \
- @KDRIVE_LIBS@
-
-if GLX
-Xsmi_LDFLAGS = $(LD_EXPORT_SYMBOLS_FLAG)
-endif
-
-Xsmi_LDADD = \
- $(SMI_LIBS) \
- @KDRIVE_LIBS@
-
-Xsmi_DEPENDENCIES = \
- libsmi.a \
- @KDRIVE_LOCAL_LIBS@
-
-relink:
- rm -f $(bin_PROGRAMS) && make $(bin_PROGRAMS)