aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/hw/kdrive/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xorg-server/hw/kdrive/src/Makefile.am')
-rw-r--r--xorg-server/hw/kdrive/src/Makefile.am14
1 files changed, 3 insertions, 11 deletions
diff --git a/xorg-server/hw/kdrive/src/Makefile.am b/xorg-server/hw/kdrive/src/Makefile.am
index 792f64a4d..7ac23c2aa 100644
--- a/xorg-server/hw/kdrive/src/Makefile.am
+++ b/xorg-server/hw/kdrive/src/Makefile.am
@@ -4,13 +4,7 @@ INCLUDES = \
AM_CFLAGS = -DHAVE_DIX_CONFIG_H
-noinst_LIBRARIES = libkdrive.a libkdrivestubs.a
-
-if KDRIVE_HW
-KDRIVE_HW_SOURCES = \
- vga.c \
- vga.h
-endif
+noinst_LTLIBRARIES = libkdrive.la libkdrivestubs.la
if XV
KDRIVE_XV_SOURCES = \
@@ -18,7 +12,7 @@ KDRIVE_XV_SOURCES = \
kxv.h
endif
-libkdrive_a_SOURCES = \
+libkdrive_la_SOURCES = \
fourcc.h \
kcmap.c \
kcurscol.c \
@@ -26,13 +20,11 @@ libkdrive_a_SOURCES = \
kdrive.h \
kinfo.c \
kinput.c \
- kkeymap.c \
kmap.c \
kmode.c \
kshadow.c \
$(KDRIVE_XV_SOURCES) \
- $(KDRIVE_HW_SOURCES) \
$(top_srcdir)/mi/miinitext.c
-libkdrivestubs_a_SOURCES = \
+libkdrivestubs_la_SOURCES = \
$(top_srcdir)/fb/fbcmap_mi.c