aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/hw/kdrive/vesa/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xorg-server/hw/kdrive/vesa/Makefile.am')
-rw-r--r--xorg-server/hw/kdrive/vesa/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/xorg-server/hw/kdrive/vesa/Makefile.am b/xorg-server/hw/kdrive/vesa/Makefile.am
new file mode 100644
index 000000000..4225dcfbc
--- /dev/null
+++ b/xorg-server/hw/kdrive/vesa/Makefile.am
@@ -0,0 +1,33 @@
+INCLUDES = \
+ @KDRIVE_INCS@ \
+ @KDRIVE_CFLAGS@
+
+noinst_LIBRARIES = libvesa.a
+
+bin_PROGRAMS = Xvesa
+
+libvesa_a_SOURCES = \
+ vesa.c \
+ vesa.h \
+ vbe.c \
+ vbe.h \
+ vga.c \
+ vga.h \
+ vm86.c \
+ vm86.h
+
+Xvesa_SOURCES = \
+ vesainit.c
+
+Xvesa_LDADD = \
+ libvesa.a \
+ @KDRIVE_LIBS@
+
+Xvesa_DEPENDENCIES = \
+ libvesa.a \
+ @KDRIVE_LOCAL_LIBS@
+
+Xvesa_LDFLAGS = $(LD_EXPORT_SYMBOLS_FLAG)
+
+relink:
+ rm -f $(bin_PROGRAMS) && make $(bin_PROGRAMS)