aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/hw/xfree86/dri2/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xorg-server/hw/xfree86/dri2/Makefile.am')
-rw-r--r--xorg-server/hw/xfree86/dri2/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/xorg-server/hw/xfree86/dri2/Makefile.am b/xorg-server/hw/xfree86/dri2/Makefile.am
new file mode 100644
index 000000000..e5bd16bd2
--- /dev/null
+++ b/xorg-server/hw/xfree86/dri2/Makefile.am
@@ -0,0 +1,16 @@
+libdri2_la_LTLIBRARIES = libdri2.la
+libdri2_la_CFLAGS = \
+ -DHAVE_XORG_CONFIG_H \
+ @GL_CFLAGS@ \
+ @DIX_CFLAGS@ @XORG_CFLAGS@ @DRI2PROTO_CFLAGS@ @LIBDRM_CFLAGS@ \
+ -I$(top_srcdir)/hw/xfree86/common \
+ -I$(top_srcdir)/hw/xfree86/os-support/bus
+
+libdri2_la_LDFLAGS = -module -avoid-version @LIBDRM_LIBS@
+libdri2_ladir = $(moduledir)/extensions
+libdri2_la_SOURCES = \
+ dri2.c \
+ dri2.h \
+ dri2ext.c
+
+sdk_HEADERS = dri2.h