aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/hw/xfree86/exa/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xorg-server/hw/xfree86/exa/Makefile.am')
-rw-r--r--xorg-server/hw/xfree86/exa/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/xorg-server/hw/xfree86/exa/Makefile.am b/xorg-server/hw/xfree86/exa/Makefile.am
new file mode 100644
index 000000000..9eb2e1797
--- /dev/null
+++ b/xorg-server/hw/xfree86/exa/Makefile.am
@@ -0,0 +1,28 @@
+module_LTLIBRARIES = libexa.la
+
+libexa_la_LDFLAGS = -avoid-version
+
+INCLUDES = \
+ $(XORG_INCS) \
+ -I$(srcdir)/../../../exa \
+ -I$(srcdir)/../../../miext/cw
+
+AM_CFLAGS = $(DIX_CFLAGS) $(XORG_CFLAGS)
+
+libexa_la_SOURCES = \
+ examodule.c
+
+libexa_la_LIBADD = \
+ ../../../exa/libexa.la
+
+include $(top_srcdir)/cpprules.in
+
+drivermandir = $(DRIVER_MAN_DIR)
+driverman_DATA = exa.$(DRIVER_MAN_SUFFIX)
+CLEANFILES = $(driverman_DATA) exa.man
+
+exa.$(DRIVER_MAN_SUFFIX): exa.man
+ -rm -f exa.$(DRIVER_MAN_SUFFIX)
+ $(LN_S) exa.man exa.$(DRIVER_MAN_SUFFIX)
+
+EXTRA_DIST = exa.man.pre