aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/hw/xfree86/loader/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xorg-server/hw/xfree86/loader/Makefile.am')
-rw-r--r--xorg-server/hw/xfree86/loader/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/xorg-server/hw/xfree86/loader/Makefile.am b/xorg-server/hw/xfree86/loader/Makefile.am
new file mode 100644
index 000000000..ef9ab9ab3
--- /dev/null
+++ b/xorg-server/hw/xfree86/loader/Makefile.am
@@ -0,0 +1,35 @@
+noinst_LIBRARIES = libloader.a
+
+INCLUDES = $(XORG_INCS) -I$(srcdir)/../parser -I$(srcdir)/../dixmods/extmod \
+ -I$(srcdir)/../vbe -I$(top_srcdir)/miext/cw -I$(srcdir)/../int10 \
+ -I$(srcdir)/../ddc -I$(srcdir)/../i2c -I$(srcdir)/../modes \
+ -I$(srcdir)/../ramdac
+
+#AM_LDFLAGS = -r
+AM_CFLAGS = -DIN_LOADER $(DIX_CFLAGS) $(XORG_CFLAGS)
+
+if XORG_LOADER_SPARC
+SPARC_SOURCES = SparcMulDiv.S
+endif
+
+EXTRA_DIST = \
+ dlloader.h \
+ loader.h \
+ loaderProcs.h \
+ SparcMulDiv.S
+
+libloader_a_SOURCES = \
+ loader.c \
+ loaderProcs.h \
+ loadext.c \
+ loadmod.c \
+ loadfont.c \
+ dlloader.c \
+ os.c \
+ dixsym.c \
+ extsym.c \
+ fontsym.c \
+ misym.c \
+ xf86sym.c \
+ sym.h \
+ $(SPARC_SOURCES)