aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/hw/xfree86/os-support/bus/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xorg-server/hw/xfree86/os-support/bus/Makefile.am')
-rw-r--r--xorg-server/hw/xfree86/os-support/bus/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/xorg-server/hw/xfree86/os-support/bus/Makefile.am b/xorg-server/hw/xfree86/os-support/bus/Makefile.am
new file mode 100644
index 000000000..d48fcb67d
--- /dev/null
+++ b/xorg-server/hw/xfree86/os-support/bus/Makefile.am
@@ -0,0 +1,38 @@
+noinst_LTLIBRARIES = libbus.la
+sdk_HEADERS = xf86Pci.h
+
+PCI_SOURCES =
+
+if XORG_BUS_LINUXPCI
+PCI_SOURCES += linuxPci.c
+endif
+
+if XORG_BUS_BSDPCI
+PCI_SOURCES += bsd_pci.c
+endif
+
+if XORG_BUS_IX86PCI
+PCI_SOURCES += ix86Pci.c
+endif
+
+if XORG_BUS_PPCPCI
+PCI_SOURCES += ppcPci.c
+endif
+
+if XORG_BUS_SPARCPCI
+PCI_SOURCES += sparcPci.c
+endif
+
+if XORG_BUS_SPARC
+PLATFORM_SOURCES = Sbus.c
+sdk_HEADERS += xf86Sbus.h
+endif
+
+libbus_la_SOURCES = Pci.c Pci.h $(PCI_SOURCES) $(PLATFORM_PCI_SOURCES) \
+ $(PLATFORM_SOURCES)
+
+INCLUDES = $(XORG_INCS)
+
+AM_CFLAGS = $(XORG_CFLAGS) $(DIX_CFLAGS)
+
+EXTRA_DIST = $(sdk_HEADERS)