aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/hw/xfree86/os-support/hurd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xorg-server/hw/xfree86/os-support/hurd/Makefile.am')
-rw-r--r--xorg-server/hw/xfree86/os-support/hurd/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/xorg-server/hw/xfree86/os-support/hurd/Makefile.am b/xorg-server/hw/xfree86/os-support/hurd/Makefile.am
new file mode 100644
index 000000000..2214b1c2d
--- /dev/null
+++ b/xorg-server/hw/xfree86/os-support/hurd/Makefile.am
@@ -0,0 +1,15 @@
+noinst_LTLIBRARIES = libhurd.la
+
+libhurd_la_SOURCES = hurd_bell.c hurd_init.c hurd_mmap.c \
+ hurd_mouse.c hurd_video.c \
+ $(srcdir)/../shared/VTsw_noop.c \
+ $(srcdir)/../shared/posix_tty.c \
+ $(srcdir)/../shared/stdResource.c \
+ $(srcdir)/../shared/sigiostubs.c \
+ $(srcdir)/../shared/pm_noop.c \
+ $(srcdir)/../shared/kmod_noop.c \
+ $(srcdir)/../shared/agp_noop.c
+
+AM_CFLAGS = -DUSESTDRES -DHAVE_SYSV_IPC $(XORG_CFLAGS) $(DIX_CFLAGS)
+
+INCLUDES = $(XORG_INCS)