aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/hw/xfree86/os-support/stub/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xorg-server/hw/xfree86/os-support/stub/Makefile.am')
-rw-r--r--xorg-server/hw/xfree86/os-support/stub/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/xorg-server/hw/xfree86/os-support/stub/Makefile.am b/xorg-server/hw/xfree86/os-support/stub/Makefile.am
new file mode 100644
index 000000000..a1156ef1b
--- /dev/null
+++ b/xorg-server/hw/xfree86/os-support/stub/Makefile.am
@@ -0,0 +1,19 @@
+noinst_LTLIBRARIES = libstub.la
+
+AM_CFLAGS = $(XORG_CFLAGS) $(DIX_CFLAGS)
+
+INCLUDES = $(XORG_INCS)
+
+libstub_la_SOURCES = \
+ $(srcdir)/../shared/VTsw_noop.c \
+ $(srcdir)/../shared/agp_noop.c \
+ $(srcdir)/../shared/ioperm_noop.c \
+ $(srcdir)/../shared/kmod_noop.c \
+ $(srcdir)/../shared/pm_noop.c \
+ $(srcdir)/../shared/vidmem.c \
+ $(srcdir)/../shared/posix_tty.c \
+ $(srcdir)/../shared/sigio.c \
+ stub_bell.c \
+ stub_bios.c \
+ stub_init.c \
+ stub_video.c