aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/hw/xfree86/parser/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xorg-server/hw/xfree86/parser/Makefile.am')
-rw-r--r--xorg-server/hw/xfree86/parser/Makefile.am21
1 files changed, 17 insertions, 4 deletions
diff --git a/xorg-server/hw/xfree86/parser/Makefile.am b/xorg-server/hw/xfree86/parser/Makefile.am
index a2774a47e..b8fab2835 100644
--- a/xorg-server/hw/xfree86/parser/Makefile.am
+++ b/xorg-server/hw/xfree86/parser/Makefile.am
@@ -1,10 +1,14 @@
if INSTALL_LIBXF86CONFIG
+noinst_LTLIBRARIES = libxf86config_internal.la
lib_LIBRARIES = libxf86config.a
+LIBHEADERS = \
+ xf86Optrec.h \
+ xf86Parser.h
else
-noinst_LIBRARIES = libxf86config.a
+noinst_LTLIBRARIES = libxf86config_internal.la
endif
-libxf86config_a_SOURCES = \
+INTERNAL_SOURCES= \
Device.c \
Files.c \
Flags.c \
@@ -22,13 +26,22 @@ libxf86config_a_SOURCES = \
DRI.c \
Extensions.c
+libxf86config_internal_la_SOURCES = \
+ $(INTERNAL_SOURCES)
+
+libxf86config_a_SOURCES = \
+ $(INTERNAL_SOURCES)
+libxf86config_a_CFLAGS = $(AM_CFLAGS)
+
AM_CFLAGS = $(DIX_CFLAGS) $(XORG_CFLAGS)
EXTRA_DIST = \
Configint.h \
configProcs.h \
+ xf86Optrec.h \
+ xf86Parser.h \
xf86tokens.h
sdk_HEADERS = \
- xf86Optrec.h \
- xf86Parser.h
+ xf86Parser.h \
+ xf86Optrec.h