aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/hw/xfree86/parser/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xorg-server/hw/xfree86/parser/Makefile.am')
-rw-r--r--xorg-server/hw/xfree86/parser/Makefile.am41
1 files changed, 41 insertions, 0 deletions
diff --git a/xorg-server/hw/xfree86/parser/Makefile.am b/xorg-server/hw/xfree86/parser/Makefile.am
new file mode 100644
index 000000000..849ee8bab
--- /dev/null
+++ b/xorg-server/hw/xfree86/parser/Makefile.am
@@ -0,0 +1,41 @@
+if INSTALL_LIBXF86CONFIG
+lib_LIBRARIES = libxf86config.a
+LIBHEADERS = \
+ xf86Optrec.h \
+ xf86Parser.h
+else
+noinst_LIBRARIES = libxf86config.a
+endif
+
+libxf86config_a_SOURCES = \
+ Device.c \
+ Files.c \
+ Flags.c \
+ Input.c \
+ Layout.c \
+ Module.c \
+ Video.c \
+ Monitor.c \
+ Pointer.c \
+ Screen.c \
+ Vendor.c \
+ read.c \
+ scan.c \
+ write.c \
+ DRI.c \
+ Extensions.c
+
+AM_CFLAGS = $(DIX_CFLAGS) $(XORG_CFLAGS)
+
+EXTRA_DIST = \
+ Configint.h \
+ configProcs.h \
+ xf86Optrec.h \
+ xf86Parser.h \
+ xf86tokens.h \
+ cpconfig.c
+
+sdk_HEADERS = \
+ $(LIBHEADERS) \
+ xf86Parser.h \
+ xf86Optrec.h