aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/hw/xgl/egl/module/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xorg-server/hw/xgl/egl/module/Makefile.am')
-rw-r--r--xorg-server/hw/xgl/egl/module/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/xorg-server/hw/xgl/egl/module/Makefile.am b/xorg-server/hw/xgl/egl/module/Makefile.am
new file mode 100644
index 000000000..c84f85c90
--- /dev/null
+++ b/xorg-server/hw/xgl/egl/module/Makefile.am
@@ -0,0 +1,15 @@
+AM_CFLAGS = \
+ $(DIX_CFLAGS) \
+ -I$(srcdir)/.. \
+ -I$(srcdir)/../.. \
+ $(XEGLMODULES_CFLAGS)
+
+libxegl_la_LDFLAGS = -avoid-version
+libxegl_la_SOURCES = xeglmodule.c
+libxegl_la_LIBADD = \
+ $(top_builddir)/hw/xgl/glx/libxegl.la \
+ $(XEGLMODULES_LIBS)
+
+moduledir = @xglmoduledir@
+
+module_LTLIBRARIES = libxegl.la