aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/hw/xgl/glxext/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xorg-server/hw/xgl/glxext/Makefile.am')
-rw-r--r--xorg-server/hw/xgl/glxext/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/xorg-server/hw/xgl/glxext/Makefile.am b/xorg-server/hw/xgl/glxext/Makefile.am
new file mode 100644
index 000000000..f79b855e7
--- /dev/null
+++ b/xorg-server/hw/xgl/glxext/Makefile.am
@@ -0,0 +1,21 @@
+SUBDIRS = module
+
+AM_CFLAGS = \
+ $(DIX_CFLAGS) \
+ -DHAVE_XGL_CONFIG_H \
+ -DHAVE_DIX_CONFIG_H \
+ $(XGLMODULES_CFLAGS) \
+ -I$(top_srcdir)/glx \
+ -I$(top_srcdir)/GL/include \
+ -I$(top_srcdir)/hw/xgl \
+ -I@MESA_SOURCE@/include \
+ -I@MESA_SOURCE@/src/mesa/glapi
+
+libxglglxext_libraries = libxglglxext.la
+libxglglxext_la_SOURCES = \
+ xglglxext.h \
+ xglglxext.c \
+ xglglxlog.c
+
+noinst_LTLIBRARIES = $(libxglglxext_libraries)
+