aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/hw/xgl/glxext/module/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xorg-server/hw/xgl/glxext/module/Makefile.am')
-rw-r--r--xorg-server/hw/xgl/glxext/module/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/xorg-server/hw/xgl/glxext/module/Makefile.am b/xorg-server/hw/xgl/glxext/module/Makefile.am
new file mode 100644
index 000000000..67653cde4
--- /dev/null
+++ b/xorg-server/hw/xgl/glxext/module/Makefile.am
@@ -0,0 +1,22 @@
+AM_CFLAGS = \
+ $(DIX_CFLAGS) \
+ -DHAVE_XGL_CONFIG_H \
+ -DHAVE_DIX_CONFIG_H \
+ $(XGLMODULES_CFLAGS) \
+ -I$(top_srcdir)/hw/xgl
+
+libglx_la_LDFLAGS = -avoid-version
+libglx_la_SOURCES = glxmodule.c
+libglx_la_LIBADD = $(top_builddir)/glx/libglx.la
+libglx_modules = libglx.la
+
+libglcore_la_LDFLAGS = -avoid-version
+libglcore_la_SOURCES = glcoremodule.c
+libglcore_la_LIBADD = $(top_builddir)/GL/mesa/libGLcore.la
+libglcore_modules = libglcore.la
+
+moduledir = @XGL_MODULE_PATH@
+
+module_LTLIBRARIES = \
+ $(libglcore_modules) \
+ $(libglx_modules)