aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/hw/xquartz/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xorg-server/hw/xquartz/Makefile.am')
-rw-r--r--xorg-server/hw/xquartz/Makefile.am27
1 files changed, 13 insertions, 14 deletions
diff --git a/xorg-server/hw/xquartz/Makefile.am b/xorg-server/hw/xquartz/Makefile.am
index 999013d1b..e5e2e9e37 100644
--- a/xorg-server/hw/xquartz/Makefile.am
+++ b/xorg-server/hw/xquartz/Makefile.am
@@ -7,35 +7,35 @@ AM_CPPFLAGS = \
-DINXQUARTZ \
-DUSE_NEW_CLUT \
-DXFree86Server \
- -I$(top_srcdir)/miext/rootless
+ -I$(top_srcdir)/miext/rootless \
+ -DX11LIBDIR=\"$(libdir)\"
-if X11APP
-X11APP_SUBDIRS = bundle
+if GLX
+GL_DIR = GL
endif
-SUBDIRS = . GL xpr $(X11APP_SUBDIRS)
-DIST_SUBDIRS = GL xpr bundle
+SUBDIRS = bundle . $(GL_DIR) xpr pbproxy mach-startup doc
+
+DIST_SUBDIRS = bundle . GL xpr pbproxy mach-startup doc
libXquartz_la_SOURCES = \
$(top_srcdir)/fb/fbcmap_mi.c \
$(top_srcdir)/mi/miinitext.c \
- $(top_srcdir)/Xext/dpmsstubs.c \
X11Application.m \
X11Controller.m \
applewm.c \
darwin.c \
darwinEvents.c \
- darwinKeyboard.c \
darwinXinput.c \
keysym2ucs.c \
pseudoramiX.c \
quartz.c \
quartzAudio.c \
quartzCocoa.m \
- quartzForeground.c \
quartzKeyboard.c \
quartzPasteboard.c \
- quartzStartup.c
+ quartzStartup.c \
+ threadSafety.c
EXTRA_DIST = \
X11Application.h \
@@ -44,14 +44,13 @@ EXTRA_DIST = \
darwinClut8.h \
darwin.h \
darwinEvents.h \
- darwinKeyboard.h \
keysym2ucs.h \
pseudoramiX.h \
quartz.h \
quartzAudio.h \
quartzCommon.h \
- quartzCursor.c \
- quartzCursor.h \
- quartzForeground.h \
quartzKeyboard.h \
- quartzPasteboard.h
+ quartzPasteboard.h \
+ sanitizedCarbon.h \
+ sanitizedCocoa.h \
+ threadSafety.h