aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/hw/xquartz/mach-startup/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xorg-server/hw/xquartz/mach-startup/Makefile.am')
-rw-r--r--xorg-server/hw/xquartz/mach-startup/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/xorg-server/hw/xquartz/mach-startup/Makefile.am b/xorg-server/hw/xquartz/mach-startup/Makefile.am
index 8e49ea8ac..0b1f8977e 100644
--- a/xorg-server/hw/xquartz/mach-startup/Makefile.am
+++ b/xorg-server/hw/xquartz/mach-startup/Makefile.am
@@ -22,7 +22,7 @@ X11_bin_LDADD = \
$(top_builddir)/dix/dixfonts.lo \
$(top_builddir)/miext/rootless/librootless.la \
$(top_builddir)/hw/xquartz/pbproxy/libxpbproxy.la \
- $(DARWIN_LIBS) $(MAIN_LIB) $(XSERVER_LIBS)
+ $(XQUARTZ_LIBS) $(XSERVER_LIBS)
X11_bin_LDFLAGS = \
$(XSERVER_SYS_LIBS) -lXplugin \
@@ -52,6 +52,8 @@ X11_bin_LDADD += \
$(top_builddir)/record/librecord.la
endif
+X11_bin_DEPENDENCIES = $(X11_bin_LDADD)
+
bin_PROGRAMS = Xquartz
dist_Xquartz_SOURCES = \