aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/miext/shadow/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xorg-server/miext/shadow/Makefile.am')
-rw-r--r--xorg-server/miext/shadow/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/xorg-server/miext/shadow/Makefile.am b/xorg-server/miext/shadow/Makefile.am
new file mode 100644
index 000000000..a73d0ec78
--- /dev/null
+++ b/xorg-server/miext/shadow/Makefile.am
@@ -0,0 +1,34 @@
+noinst_LTLIBRARIES = libshadow.la
+
+AM_CFLAGS = $(DIX_CFLAGS)
+
+INCLUDES = -I$(top_srcdir)/hw/xfree86/os-support
+
+if XORG
+sdk_HEADERS = shadow.h
+endif
+
+libshadow_la_SOURCES = \
+ shadow.c \
+ shadow.h \
+ shalloc.c \
+ shpacked.c \
+ shplanar8.c \
+ shplanar.c \
+ shrot16pack_180.c \
+ shrot16pack_270.c \
+ shrot16pack_270YX.c \
+ shrot16pack_90.c \
+ shrot16pack_90YX.c \
+ shrot16pack.c \
+ shrot32pack_180.c \
+ shrot32pack_270.c \
+ shrot32pack_90.c \
+ shrot32pack.c \
+ shrot8pack_180.c \
+ shrot8pack_270.c \
+ shrot8pack_90.c \
+ shrot8pack.c \
+ shrotate.c \
+ shrotpack.h \
+ shrotpackYX.h