aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/xkbdata.src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xorg-server/xkbdata.src/Makefile.am')
-rw-r--r--xorg-server/xkbdata.src/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/xorg-server/xkbdata.src/Makefile.am b/xorg-server/xkbdata.src/Makefile.am
new file mode 100644
index 000000000..b044dc1d2
--- /dev/null
+++ b/xorg-server/xkbdata.src/Makefile.am
@@ -0,0 +1,27 @@
+AUTOMAKE_OPTIONS = foreign
+
+SUBDIRS = compat geometry keycodes keymap po rules semantics symbols types docs
+
+EXTRA_DIST=config.rpath COPYING CREDITS README \
+ autogen.sh \
+ xkeyboard-config.spec \
+ xkeyboard-config.spec.in \
+ intltool-extract.in intltool-merge.in intltool-update.in
+
+DISTCLEANFILES=intltool-extract intltool-merge intltool-update
+
+# ACLOCAL_AMFLAGS = -I m4
+
+if CREATE_XKBCOMP_SYMLINK
+install-xkbcomp:
+ ln -sf $(XKBCOMP) $(DESTDIR)$(xkb_base)/xkbcomp
+
+else
+install-xkbcomp:
+
+endif
+
+install-data-hook: install-xkbcomp
+
+sync-po:
+ rsync -Lrtvz translationproject.org::tp/latest/xkeyboard-config/ po