aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2020-09-17 19:25:00 +0000
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2020-09-17 19:28:45 +0000
commit8e29a45e456baf232196e8fa2fc5eae50be66993 (patch)
tree0ecbff00fa526860b3458e152f02441c5caaf668 /debian/rules
parent187c3ff5d4029549f2603d3dc014b92b3a9ac21f (diff)
downloadRWA.Support.DesktopApp-8e29a45e456baf232196e8fa2fc5eae50be66993.tar.gz
RWA.Support.DesktopApp-8e29a45e456baf232196e8fa2fc5eae50be66993.tar.bz2
RWA.Support.DesktopApp-8e29a45e456baf232196e8fa2fc5eae50be66993.zip
debian/: Initial draft for creating DEB packages.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules13
1 files changed, 13 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..e4bab5e
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,13 @@
+#!/usr/bin/make -f
+
+export DPKG_GENSYMBOLS_CHECK_LEVEL=4
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/buildflags.mk
+
+%:
+ dh $@
+
+get-orig-source:
+ uscan --noconf --force-download --rename --download-current-version --destdir=..