aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2020-09-17 21:58:56 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2020-09-17 21:59:27 +0200
commit72b52affbb847a20fa0abae96e78fec980d71b67 (patch)
treef5a2553b12ec16220a375d958ec70654eec610ed /debian/rules
parent77fca6897facf95c58f4f3bcb87df19b562fc0c5 (diff)
downloadRWA.Support.SessionService-72b52affbb847a20fa0abae96e78fec980d71b67.tar.gz
RWA.Support.SessionService-72b52affbb847a20fa0abae96e78fec980d71b67.tar.bz2
RWA.Support.SessionService-72b52affbb847a20fa0abae96e78fec980d71b67.zip
debian/: Initial draft for creating DEB packages.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules13
1 files changed, 13 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..fc27a22
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,13 @@
+#!/usr/bin/make -f
+
+export DPKG_GENSYMBOLS_CHECK_LEVEL=4
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/buildflags.mk
+
+%:
+ dh $@ --with python3
+
+get-orig-source:
+ uscan --noconf --force-download --rename --download-current-version --destdir=..