aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorJonathan Weth <git@jonathanweth.de>2021-06-23 12:33:28 +0200
committerJonathan Weth <git@jonathanweth.de>2021-06-23 12:33:28 +0200
commited1d15aa02b3c7c1350a5204861d1f8678550fbb (patch)
tree51d4aa7cdee4f90b5f2c3a4188cb80519dd2342d /pyproject.toml
parent74e02d1953c1ee03a4e7dfc73e80318a24ba56a7 (diff)
downloadRWA.Support.SessionService-ed1d15aa02b3c7c1350a5204861d1f8678550fbb.tar.gz
RWA.Support.SessionService-ed1d15aa02b3c7c1350a5204861d1f8678550fbb.tar.bz2
RWA.Support.SessionService-ed1d15aa02b3c7c1350a5204861d1f8678550fbb.zip
Restructure project directory and provide script for session service
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml10
1 files changed, 10 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 19c48e6..b742893 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -8,6 +8,10 @@ authors = [
"Jonathan Weth <dev@jonathanweth.de>"
]
license = "GPL-2.0-or-later"
+packages = [
+ { include = "rwa/" },
+]
+include = ["README.rst", "LICENCE", "org.ArcticaProject.RWASupportSessionService.service", "docs/*", "docs/*/**"]
[tool.poetry.dependencies]
python = "^3.7"
@@ -25,6 +29,12 @@ dynaconf = "^3.0.0"
sphinx = "^3.0"
sphinx-autodoc-typehints = "^1.7"
+[tool.poetry.scripts]
+rwa-support-sessionservice = 'rwa.support.sessionservice.service:main'
+
+[tool.black]
+line-length = 100
+
[build-system]
requires = ["poetry>=0.12"]
build-backend = "poetry.masonry.api"