aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 204dc99..641b182 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -6,7 +6,7 @@ authors = ["Jonathan Weth <git@jonathanweth.de>"]
license = "GPL-2.0-or-later"
[tool.poetry.dependencies]
-python = "^3.5"
+python = "^3.6"
dbus-python = "^1.2.16"
PyGObject = "^3.36.1"
port_for = "^0.4"
@@ -17,6 +17,8 @@ flask = "^1.1.2"
argparse = "^1.0.10"
[tool.poetry.dev-dependencies]
+sphinx = "^3.0"
+sphinx-autodoc-typehints = "^1.7"
[build-system]
requires = ["poetry>=0.12"]