aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMihai Moldovan <ionic@ionic.de>2022-12-06 03:29:30 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2023-02-06 08:30:01 +0100
commit131bcb9889b9eb9b8eeb895f23ae1d53a25aefe8 (patch)
tree9947f573c11dd278ff81c0bdf1487e5aa6402c99 /configure.ac
parent41bd371dda0af150b729e5430450595376361cc0 (diff)
downloadarctica-greeter-131bcb9889b9eb9b8eeb895f23ae1d53a25aefe8.tar.gz
arctica-greeter-131bcb9889b9eb9b8eeb895f23ae1d53a25aefe8.tar.bz2
arctica-greeter-131bcb9889b9eb9b8eeb895f23ae1d53a25aefe8.zip
src/: add util.vala, wrapping a GTK 3 function for use within vala.
Since this function is only needed for and available in GTK 3, add configure checks for GTK 4.0 and higher as well. We will use this function later on.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 222556a..7619254 100644
--- a/configure.ac
+++ b/configure.ac
@@ -91,6 +91,16 @@ if test x$gtk_check_pass = xyes ; then
AC_SUBST([AM_VALAFLAGS])
fi
+dnl ###########################################################################
+dnl Check for GTK version - 4.0
+dnl ###########################################################################
+
+PKG_CHECK_MODULES(GTK_4_0, gtk4 >= 4.0.0 , gtk4_check_pass=yes, gtk4_check_pass=no)
+if test x$gtk4_check_pass = xyes ; then
+ AM_VALAFLAGS="$AM_VALAFLAGS -D HAVE_GTK_4_0"
+ AC_SUBST([AM_VALAFLAGS])
+fi
+
dnl ##########################################################################
dnl Remote Logon Dependencies
dnl ##########################################################################