aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2015-09-21 17:24:51 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2015-09-21 19:40:03 +0200
commit88523096d08e7bd400ce0b6f53857a2afe1647bc (patch)
tree67e09477dc89bbe1b2f63ae89955ab229bc0247f /configure.ac
parent1896346d954b3ecf42d8f366d97521dc13213a52 (diff)
downloadarctica-greeter-88523096d08e7bd400ce0b6f53857a2afe1647bc.tar.gz
arctica-greeter-88523096d08e7bd400ce0b6f53857a2afe1647bc.tar.bz2
arctica-greeter-88523096d08e7bd400ce0b6f53857a2afe1647bc.zip
Make arctica-greeter build on Debian and Ubuntu alike.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 22 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 86ddaef..cf784de 100644
--- a/configure.ac
+++ b/configure.ac
@@ -37,11 +37,29 @@ AC_DEFINE_UNQUOTED([INDICATOR_FILE_DIR], ["${prefix}/share/unity/indicators"], [
INDICATORDIR=`$PKG_CONFIG --variable=indicatordir indicator3-0.4`
AC_SUBST(INDICATORDIR)
-MSD_BINARY=`$PKG_CONFIG --variable=binary mate-settings-daemon`
-if test -z "$MSD_BINARY"; then
- AC_MSG_ERROR([Could not find path to mate-settings-daemon binary])
+if $PKG_CONFIG --exists unity-settings-daemon; then
+ USD_BINARY=`$PKG_CONFIG --variable=binary unity-settings-daemon`
+ if test -z "$USD_BINARY"; then
+ AC_MSG_NOTICE([Could not find path to unity-settings-daemon binary])
+ else
+ SD_BINARY="$USD_BINARY"
+ fi
+
+elif $PKG_CONFIG --exists mate-settings-daemon; then
+ MSD_BINARY=`$PKG_CONFIG --variable=binary mate-settings-daemon`
+ if test -z "$MSD_BINARY"; then
+ AC_MSG_NOTICE([Could not find path to mate-settings-daemon binary])
+ else
+ SD_BINARY="$MSD_BINARY"
+ fi
+
+fi
+
+if test -z "$SD_BINARY"; then
+ AC_MSG_ERROR([Could not find any of the supported X11 settings daemons])
+else
+ AC_DEFINE_UNQUOTED([SD_BINARY], ["$MSD_BINARY"], [Path to m-s-d])
fi
-AC_DEFINE_UNQUOTED([MSD_BINARY], ["$MSD_BINARY"], [Path to m-s-d])
dnl ###########################################################################
dnl Internationalization