aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMihai Moldovan <ionic@ionic.de>2023-10-05 14:05:56 +0200
committerMihai Moldovan <ionic@ionic.de>2023-10-05 14:05:56 +0200
commitdf7825b0044a7c6be526e93a263f2f4f2c1143fa (patch)
tree1d2cf58f89dcc854a75a42995e9734b68915bf2a /debian/rules
parent55cfcc8b789c23b891d32e50e7986bafe9cee280 (diff)
parenta94b2292e8576ccddf1cbd5159f24f6265c85e73 (diff)
downloadarctica-greeter-df7825b0044a7c6be526e93a263f2f4f2c1143fa.tar.gz
arctica-greeter-df7825b0044a7c6be526e93a263f2f4f2c1143fa.tar.bz2
arctica-greeter-df7825b0044a7c6be526e93a263f2f4f2c1143fa.zip
Merge branch 'sunweaver-mr/libexecdir-debian'
Attributes GH PR #80: https://github.com/ArcticaProject/arctica-greeter/pull/80
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 3 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 76c7912..5a34f02 100755
--- a/debian/rules
+++ b/debian/rules
@@ -20,11 +20,11 @@ override_dh_autoreconf:
override_dh_auto_configure:
set -x; if [ -x "$(GUEST_WRAPPER_BINARY_LIBEXEC)" ]; then \
- dh_auto_configure -- GUEST_WRAPPER_BINARY=/usr/libexec/lightdm/lightdm-guest-session; \
+ dh_auto_configure -- --libexecdir=/usr/libexec GUEST_WRAPPER_BINARY=/usr/libexec/lightdm/lightdm-guest-session; \
elif [ -x "${GUEST_WRAPPER_BINARY_M_LIB}" ]; then \
- dh_auto_configure -- GUEST_WRAPPER_BINARY=/usr/lib/$(DEB_HOST_MULTIARCH)/lightdm/lightdm-guest-session; \
+ dh_auto_configure -- --libexecdir=/usr/libexec GUEST_WRAPPER_BINARY=/usr/lib/$(DEB_HOST_MULTIARCH)/lightdm/lightdm-guest-session; \
elif [ -x "${GUEST_WRAPPER_BINARY_LIB}" ]; then \
- dh_auto_configure -- GUEST_WRAPPER_BINARY=/usr/lib/lightdm/lightdm-guest-session; \
+ dh_auto_configure -- --libexecdir=/usr/libexec GUEST_WRAPPER_BINARY=/usr/lib/lightdm/lightdm-guest-session; \
else \
echo "Error: GUEST_WRAPPER_BINARY (lightdm-guest-session executable from LightDM) not found!"; \
exit 1; \