aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2014-11-02 20:41:17 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2014-11-02 20:41:17 +0100
commit4ae9e07bb3f6af341a568888f2487712d7a40829 (patch)
tree3dd4182a962cc361efd1ae5a56492b45a0e9bd67 /debian
parent8e2d33d3a5d17531a36e629bcf4c0bc36cbf1cfe (diff)
downloadarctica-greeter-4ae9e07bb3f6af341a568888f2487712d7a40829.tar.gz
arctica-greeter-4ae9e07bb3f6af341a568888f2487712d7a40829.tar.bz2
arctica-greeter-4ae9e07bb3f6af341a568888f2487712d7a40829.zip
upload to ppa:x2go/stable+ppa (ubuntu/14.04.10-0ubuntu1+x2go1)
* Non-maintainer upload. * Add X2Go support to RLS. * Turn package into format 3.0 (quilt). * Provide via ppa:x2go/ppa and ppa:x2go/stable on Launchpad.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog10
-rw-r--r--debian/patches/01_x2go+rls.patch39
-rw-r--r--debian/patches/series1
-rw-r--r--debian/source/format2
4 files changed, 51 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index a19f10c..19c1e0a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+unity-greeter (14.04.10-0ubuntu1+x2go1) trusty; urgency=medium
+
+ * Non-maintainer upload.
+ * Add X2Go support to RLS.
+ * Turn package into format 3.0 (quilt).
+ * Provide via ppa:x2go/ppa and ppa:x2go/stable on Launchpad.
+
+
+ -- Mike Gabriel <mike.gabriel@das-netzwerkteam.de> Sun, 02 Nov 2014 19:12:50 +0100
+
unity-greeter (14.04.10-0ubuntu1) trusty; urgency=medium
* New upstream release:
diff --git a/debian/patches/01_x2go+rls.patch b/debian/patches/01_x2go+rls.patch
new file mode 100644
index 0000000..8b3135f
--- /dev/null
+++ b/debian/patches/01_x2go+rls.patch
@@ -0,0 +1,39 @@
+=== modified file 'src/user-list.vala'
+--- a/src/user-list.vala
++++ b/src/user-list.vala
+@@ -20,7 +20,7 @@
+
+ int remote_server_field_sort_function (RemoteServerField? item1, RemoteServerField? item2)
+ {
+- string[] sorted_fields = { "domain", "username", "email", "password" };
++ string[] sorted_fields = { "domain", "x2gosession" , "username", "email", "password"};
+ foreach (var field in sorted_fields)
+ {
+ if (item1.type == field)
+@@ -702,6 +702,13 @@
+ entry.text = default_value;
+ widget = entry;
+ }
++ else if (field.type == "x2gosession")
++ {
++ var prompt = add_prompt (_("X2Go Session:"));
++ prompt.text = default_value;
++ prompt.sensitive = true;
++ widget = prompt;
++ }
+ else if (field.type == "domain")
+ {
+ string[] domainsArray = {};
+@@ -1077,6 +1084,12 @@
+ var answer = field != null ? field.text : "";
+ UnityGreeter.singleton.respond (answer);
+ }
++ else if (text == "x2gosession:")
++ {
++ Gtk.Entry field = current_remote_fields.get ("x2gosession") as Gtk.Entry;
++ var answer = field != null ? field.text : "";
++ UnityGreeter.singleton.respond (answer);
++ }
+ }
+ else
+ base.show_prompt_cb (text, type);
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..36c571f
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+01_x2go+rls.patch
diff --git a/debian/source/format b/debian/source/format
index 89ae9db..163aaf8 100644
--- a/debian/source/format
+++ b/debian/source/format
@@ -1 +1 @@
-3.0 (native)
+3.0 (quilt)