aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2014-11-02 20:40:40 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2014-11-02 20:40:40 +0100
commit8e2d33d3a5d17531a36e629bcf4c0bc36cbf1cfe (patch)
tree5def29ecbadc8873d62ebea6badc27c99b874bfe /src/Makefile.am
downloadarctica-greeter-8e2d33d3a5d17531a36e629bcf4c0bc36cbf1cfe.tar.gz
arctica-greeter-8e2d33d3a5d17531a36e629bcf4c0bc36cbf1cfe.tar.bz2
arctica-greeter-8e2d33d3a5d17531a36e629bcf4c0bc36cbf1cfe.zip
Imported Upstream version 14.04.10
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am76
1 files changed, 76 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..b890ee0
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,76 @@
+# -*- Mode: Automake; indent-tabs-mode: t; tab-width: 4 -*-
+
+sbin_PROGRAMS = unity-greeter
+noinst_PROGRAMS = logo-generator
+
+unity_greeter_SOURCES = \
+ config.vapi \
+ fixes.vapi \
+ indicator.vapi \
+ animate-timer.vala \
+ background.vala \
+ cached-image.vala \
+ cairo-utils.vala \
+ email-autocompleter.vala \
+ dash-box.vala \
+ dash-button.vala \
+ dash-entry.vala \
+ fadable.vala \
+ fadable-box.vala \
+ fading-label.vala \
+ flat-button.vala \
+ greeter-list.vala \
+ list-stack.vala \
+ main-window.vala \
+ menu.vala \
+ menubar.vala \
+ prompt-box.vala \
+ session-list.vala \
+ remote-login-service.vala \
+ settings.vala \
+ settings-daemon.vala \
+ shutdown-dialog.vala \
+ toggle-box.vala \
+ unity-greeter.vala \
+ user-list.vala \
+ user-prompt-box.vala
+
+logo_generator_SOURCES = logo-generator.vala
+
+unity_greeter_CFLAGS = \
+ $(UNITY_GREETER_CFLAGS) \
+ -w \
+ -DGNOME_DESKTOP_USE_UNSTABLE_API \
+ -DGETTEXT_PACKAGE=\"$(GETTEXT_PACKAGE)\" \
+ -DLOCALEDIR=\""$(localedir)"\" \
+ -DVERSION=\"$(VERSION)\" \
+ -DCONFIG_FILE=\""$(sysconfdir)/lightdm/unity-greeter.conf"\" \
+ -DPKGDATADIR=\""$(pkgdatadir)"\" \
+ -DINDICATORDIR=\""$(INDICATORDIR)"\"
+
+logo_generator_CFLAGS = $(unity_greeter_CFLAGS)
+
+unity_greeter_VALAFLAGS = \
+ --pkg posix \
+ --pkg gtk+-3.0 \
+ --pkg gdk-x11-3.0 \
+ --pkg gio-unix-2.0 \
+ --pkg x11 \
+ --pkg liblightdm-gobject-1 \
+ --pkg libcanberra \
+ --pkg gio-2.0 \
+ --pkg pixman-1 \
+ --target-glib 2.32
+
+logo_generator_VALAFLAGS = $(unity_greeter_VALAFLAGS)
+
+unity_greeter_LDADD = \
+ $(UNITY_GREETER_LIBS) \
+ -lm
+
+logo_generator_LDADD = $(unity_greeter_LDADD)
+
+unity_greeter_vala.stamp: $(top_srcdir)/config.h
+
+DISTCLEANFILES = \
+ Makefile.in