aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules22
1 files changed, 22 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..ff8fb91
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,22 @@
+#!/usr/bin/make -f
+
+LDFLAGS+=-Wl,--as-needed
+
+%:
+ dh $@ --with autoreconf --fail-missing
+
+override_dh_autoreconf:
+ NOCONFIGURE=1 dh_autoreconf ./autogen.sh
+
+
+override_dh_auto_build:
+ dh_auto_build
+ ./src/logo-generator --logo data/logo-bare.png --text '14.04 LTS' --output logo.png
+
+override_dh_auto_install:
+ dh_auto_install
+ cp logo.png debian/unity-greeter/usr/share/unity-greeter/logo.png
+
+override_dh_auto_clean:
+ dh_auto_clean
+ rm -f logo.png