aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2015-09-14 05:33:34 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2015-09-14 06:17:04 +0200
commitd5cc21475e473dd2ea3e2afdab5ad1a46533f1ea (patch)
tree8db2df227b9d47243259eaf8e21a3b5fcc6962c1 /debian/rules
downloadarctica-keyring-d5cc21475e473dd2ea3e2afdab5ad1a46533f1ea.tar.gz
arctica-keyring-d5cc21475e473dd2ea3e2afdab5ad1a46533f1ea.tar.bz2
arctica-keyring-d5cc21475e473dd2ea3e2afdab5ad1a46533f1ea.zip
initial commit
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules22
1 files changed, 22 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..da5bb09
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,22 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/class/makefile.mk
+include /usr/share/cdbs/1/rules/debhelper.mk
+
+export PREFIX=/usr
+export DESTDIR=debian/tmp
+
+DEB_BUILD_PARALLEL = 1
+DEB_INSTALL_DOCS_ALL = README
+
+DEB_MAKE_CHECK_TARGET=test
+DEB_MAKE_INSTALL_TARGET=install
+
+common-install-indep:: remove-cruft
+common-install-arch:: remove-cruft
+
+remove-cruft::
+# Nothing to do here, right now...
+
+get-orig-source:
+ uscan --noconf --force-download --rename --download-current-version --destdir=..