aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-05-04 13:04:58 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-05-04 13:05:00 +0200
commit81db2957f86a86c96263dba63664d5d97f9937d5 (patch)
treea47883116399664bc8cccc0cd12a8125d5b28adb /CMakeLists.txt
parentccd0834804ccb097dd2ee7d86618ff0cffd8389d (diff)
downloadayatana-ido-81db2957f86a86c96263dba63664d5d97f9937d5.tar.gz
ayatana-ido-81db2957f86a86c96263dba63664d5d97f9937d5.tar.bz2
ayatana-ido-81db2957f86a86c96263dba63664d5d97f9937d5.zip
CMakeLists.txt: Move coverage report generation macro into basefolder's CMakeLists.txt file.
With the previous approach, only coverage of the tests/ subfolder was reported (which always should be 100%). With this change, also coverage of the files in src/ is reported.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b039352..70b509f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -51,6 +51,15 @@ if (ENABLE_TESTS)
enable_testing()
add_subdirectory(example)
add_subdirectory(tests)
+ # coverage
+ if (ENABLE_COVERAGE)
+ find_package(CoverageReport)
+ ENABLE_COVERAGE_REPORT(
+ TARGETS "ayatana-ido3-0.4"
+ TESTS "gtest-menuitems"
+ FILTER /usr/include ${CMAKE_BINARY_DIR}/*
+ )
+ endif()
endif()
# Display config info