aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJami Kettunen <jami.kettunen@protonmail.com>2023-02-26 16:26:47 +0200
committerJami Kettunen <jami.kettunen@protonmail.com>2023-02-26 17:11:31 +0200
commit889c006f9fcc57889ccb7d10ebadcf53463ae24c (patch)
tree6ac169eda39ae3b04e8b7198af2bdc2f1421e21b /CMakeLists.txt
parentf692439d1ef5dc858d284cf36c79e23b97b5540e (diff)
downloadayatana-ido-889c006f9fcc57889ccb7d10ebadcf53463ae24c.tar.gz
ayatana-ido-889c006f9fcc57889ccb7d10ebadcf53463ae24c.tar.bz2
ayatana-ido-889c006f9fcc57889ccb7d10ebadcf53463ae24c.zip
cmake: Enable building tests by default
We really should do this by default across the board to catch issues with the testing infrastructure; what's the point of having tests if they're not even being actively exercised across a wide range of distributions with varying configurations? :p
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bc4295f..7bbc464 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,7 +9,7 @@ endif(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
# Options
-option(ENABLE_TESTS "Enable all tests and checks" OFF)
+option(ENABLE_TESTS "Enable all tests and checks" ON)
option(ENABLE_COVERAGE "Enable coverage reports (includes enabling all tests and checks)" OFF)
option(ENABLE_WERROR "Treat all build warnings as errors" OFF)