aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-10-26 10:09:40 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-10-26 10:09:40 +0200
commite128c176615e7b77511ff632f96c208033b63b86 (patch)
tree52dc6be65d7f7688770620986d271454fc8dd8e2 /CMakeLists.txt
parentbde3617182582e2c0c341b847b65e4f280115736 (diff)
downloadayatana-ido-e128c176615e7b77511ff632f96c208033b63b86.tar.gz
ayatana-ido-e128c176615e7b77511ff632f96c208033b63b86.tar.bz2
ayatana-ido-e128c176615e7b77511ff632f96c208033b63b86.zip
Revert ".build.yml: Drop autogen.sh support; Run unit tests in build_scripts: target."
This reverts commit bde3617182582e2c0c341b847b65e4f280115736.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt33
1 files changed, 2 insertions, 31 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d3713fd..7d12f76 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -29,34 +29,7 @@ endif()
# Check for prerequisites
-option(FLAVOUR_GTK3 "Build against GTK+-3.0" ON)
-option(FLAVOUR_GTK4 "Build against GTK+-4.0" OFF)
-option(ENABLE_LOADER "Build Ayatana Indicator Loader" ON)
-option(ENABLE_IDO "Enable IDO specific code" ON)
-
-if (FLAVOUR_GTK4)
- set (FLAVOUR_GTK3 OFF)
- set (ayatana_ido_gtkver "ayatana-ido4")
-endif()
-if (FLAVOUR_GTK3)
- set (FLAVOUR_GTK4 OFF)
- set (ayatana_ido_gtkver "ayatana-ido3")
-endif()
-
-set(DEPS glib-2.0>=2.58)
-
-if (FLAVOUR_GTK4)
- set(DEPS
- ${DEPS}
- gtk+-4.0>=3.91
- )
-endif()
-if (FLAVOUR_GTK3)
- set(DEPS
- ${DEPS}
- gtk+-3.0>=3.24
- )
-endif()
+set(DEPS glib-2.0>=2.58 gtk+-3.0>=3.24)
find_package (PkgConfig REQUIRED)
pkg_check_modules(PROJECT_DEPS REQUIRED ${DEPS})
@@ -92,7 +65,7 @@ if (ENABLE_TESTS)
if (ENABLE_COVERAGE)
find_package(CoverageReport)
ENABLE_COVERAGE_REPORT(
- TARGETS "${ayatana_ido_gtkver}-0.4"
+ TARGETS "ayatana-ido3-0.4"
TESTS "gtest-menuitems"
FILTER /usr/include ${CMAKE_BINARY_DIR}/*
)
@@ -102,7 +75,5 @@ endif()
# Display config info
message(STATUS "Install prefix: ${CMAKE_INSTALL_PREFIX}")
-message(STATUS "GTK+-4.0 build: ${FLAVOUR_GTK4}")
-message(STATUS "GTK+-3.0 build: ${FLAVOUR_GTK3}")
message(STATUS "Unit tests: ${ENABLE_TESTS}")
message(STATUS "Build with -Werror: ${ENABLE_WERROR}")