aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2023-05-05 23:33:50 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2023-05-05 23:33:50 +0200
commite74e767ad6c67788fd7ef3bb45a5d6a722c71e12 (patch)
treedf332d910d3c6742841c56bfd7795a45ffdec164 /CMakeLists.txt
parentc730328e1986ff82a4bec5b26a1055b4ea4c0846 (diff)
parent876a9fa2754a7defcec201d726f8f502ae239a2c (diff)
downloadayatana-ido-e74e767ad6c67788fd7ef3bb45a5d6a722c71e12.tar.gz
ayatana-ido-e74e767ad6c67788fd7ef3bb45a5d6a722c71e12.tar.bz2
ayatana-ido-e74e767ad6c67788fd7ef3bb45a5d6a722c71e12.zip
Merge branch 'tari01-pr/level-item'
Attributes GH PR #65: https://github.com/AyatanaIndicators/ayatana-ido/pull/65
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ceccb83..df0b8bb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -37,6 +37,11 @@ else()
add_definitions("-Wall")
endif()
+# Thread fix for old CMake
+
+set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -pthread")
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -pthread")
+
# Check for prerequisites
set(DEPS glib-2.0>=2.58 gtk+-3.0>=3.24)