aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2023-02-26 22:42:08 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2023-02-26 22:42:53 +0100
commitf19a5f472d282de32ca270afc68a6da8d4edca61 (patch)
tree17c0468a9fd7e5880c28c65afe500f74a0146495 /CMakeLists.txt
parent109100e2d031d413d89fa67c8c417f98992f317a (diff)
downloadayatana-ido-f19a5f472d282de32ca270afc68a6da8d4edca61.tar.gz
ayatana-ido-f19a5f472d282de32ca270afc68a6da8d4edca61.tar.bz2
ayatana-ido-f19a5f472d282de32ca270afc68a6da8d4edca61.zip
Revert "cmake: Enable building tests by default"
This reverts commit 889c006f9fcc57889ccb7d10ebadcf53463ae24c. As discussed with co-maintainer Robert Tari, tests shall be enabled by distro packagers (if wanted) and in our CI builds.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 63cfec4..ceccb83 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,7 +9,7 @@ endif(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
# Options
-option(ENABLE_TESTS "Enable all tests and checks" ON)
+option(ENABLE_TESTS "Enable all tests and checks" OFF)
option(ENABLE_COVERAGE "Enable coverage reports (includes enabling all tests and checks)" OFF)
option(ENABLE_WERROR "Treat all build warnings as errors" OFF)