aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2023-04-04 21:21:50 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2023-05-05 23:31:52 +0200
commitfc636cea8077765e5f35603960bc64928269f4f0 (patch)
treea6b2878c22c8ce3ef80a565b9dd1e11b632889b0 /CMakeLists.txt
parentc730328e1986ff82a4bec5b26a1055b4ea4c0846 (diff)
downloadayatana-ido-fc636cea8077765e5f35603960bc64928269f4f0.tar.gz
ayatana-ido-fc636cea8077765e5f35603960bc64928269f4f0.tar.bz2
ayatana-ido-fc636cea8077765e5f35603960bc64928269f4f0.zip
CMakeLists.txt: Add threads fix for old CMake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ceccb83..df0b8bb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -37,6 +37,11 @@ else()
add_definitions("-Wall")
endif()
+# Thread fix for old CMake
+
+set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -pthread")
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -pthread")
+
# Check for prerequisites
set(DEPS glib-2.0>=2.58 gtk+-3.0>=3.24)