aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2012-04-12 10:18:01 -0500
committerCharles Kerr <charles.kerr@canonical.com>2012-04-12 10:18:01 -0500
commitceb09d1a5aa9f8659765a11f37c2778058d218ab (patch)
tree1e6e7eda17eddc30ada80519199646570102c765 /configure.ac
parenta4ad20e59551cd88b3811176b6ded951c29ecdf2 (diff)
parent0597fa88bbafb21e71a1e2440423bc912c09f16b (diff)
downloadayatana-ido-ceb09d1a5aa9f8659765a11f37c2778058d218ab.tar.gz
ayatana-ido-ceb09d1a5aa9f8659765a11f37c2778058d218ab.tar.bz2
ayatana-ido-ceb09d1a5aa9f8659765a11f37c2778058d218ab.zip
merge lp:~allanlesage/ido/TDD to add targets to autotools build for code-coverage reporting. For more information, see this blog post: http://qualityhour.wordpress.com/2012/01/29/test-coverage-tutorial-for-cc-autotools-projects/ .
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 312276c..c7b4864 100644
--- a/configure.ac
+++ b/configure.ac
@@ -117,6 +117,16 @@ AS_IF([test "x$enable_maintainer_flags" = "xyes" && test "x$GCC" = "xyes"],
AC_SUBST(MAINTAINER_CFLAGS)
+dnl = gcov Coverage Reporting =================================================
+
+m4_include([m4/gcov.m4])
+AC_TDD_GCOV
+AM_CONDITIONAL([HAVE_GCOV], [test "x$ac_cv_check_gcov" = xyes])
+AM_CONDITIONAL([HAVE_LCOV], [test "x$ac_cv_check_lcov" = xyes])
+AM_CONDITIONAL([HAVE_GCOVR], [test "x$ac_cv_check_gcovr" = xyes])
+AC_SUBST(COVERAGE_CFLAGS)
+AC_SUBST(COVERAGE_CXXFLAGS)
+AC_SUBST(COVERAGE_LDFLAGS)
dnl = GTK Doc Check ===========================================================
@@ -140,6 +150,7 @@ echo " ==============================="
echo ""
echo " Prefix : ${prefix}"
echo " GTK : ${with_gtk}"
+echo " gcov : ${use_gcov}"
echo ""
echo " Documentation: ${enable_gtk_doc}"
echo ""