aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2012-08-22 09:39:22 -0500
committerCharles Kerr <charles.kerr@canonical.com>2012-08-22 09:39:22 -0500
commitfc8fad250f546c4923d4839a77e897cf6b75dc04 (patch)
treedbd84b9aad1cdad597ce991d6a4376a4889ec9d7 /configure.ac
parent84a63033c820bf890e0bcecd2f07cc325c44e9e9 (diff)
parent8f279d3f26f588bb022f3f0d05edff6858035eab (diff)
downloadayatana-ido-fc8fad250f546c4923d4839a77e897cf6b75dc04.tar.gz
ayatana-ido-fc8fad250f546c4923d4839a77e897cf6b75dc04.tar.bz2
ayatana-ido-fc8fad250f546c4923d4839a77e897cf6b75dc04.zip
sync with lp:ido
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 10 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 8b69cca..963de1e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,9 +1,9 @@
#
# shamelessly stolen from clutter-gtk
#
-m4_define([ido_major_version], [0])
-m4_define([ido_minor_version], [3])
-m4_define([ido_micro_version], [4])
+m4_define([ido_major_version], [12])
+m4_define([ido_minor_version], [10])
+m4_define([ido_micro_version], [0])
m4_define([ido_api_version],
[ido_major_version.ido_minor_version])
@@ -77,8 +77,14 @@ AC_C_CONST
AC_FUNC_MALLOC
AC_FUNC_MMAP
AC_CHECK_FUNCS([memset munmap strcasecmp strdup])
+AC_CHECK_LIBM
+
+GLIB_REQUIRED_VERSION=2.32.0
+GTK_REQUIRED_VERSION=3.4.0
+
+PKG_CHECK_MODULES(GTK,[gtk+-3.0 >= $GTK_REQUIRED_VERSION
+ glib-2.0 >= $GLIB_REQUIRED_VERSION])
-PKG_CHECK_MODULES(GTK, gtk+-3.0 >= 3.0.0)
AC_SUBST(GTK_CFLAGS)
AC_SUBST(GTK_LIBS)