aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-04-20 14:05:24 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-04-21 20:57:30 +0200
commit6b4eb421cd56a538f732d8597b683980a1c86998 (patch)
tree100f191d37cbbe1fd0fc33e3811c2d0809047b91 /debian/rules
parentd62ba3a055e1fa6cacfa34e8733784a68324ce78 (diff)
downloadayatana-ido-6b4eb421cd56a538f732d8597b683980a1c86998.tar.gz
ayatana-ido-6b4eb421cd56a538f732d8597b683980a1c86998.tar.bz2
ayatana-ido-6b4eb421cd56a538f732d8597b683980a1c86998.zip
debian/: Adjust to build system switch-over to CMake.
Fixes AyatanaIndicators/ayatana-ido#27
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 13 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index b4a0a75..e2bd5ed 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,11 +6,18 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk
+NULL :=
+
+DEB_CMAKE_EXTRA_FLAGS = \
+ -DENABLE_TESTS=ON \
+ -DENABLE_COVERAGE=OFF \
+ $(NULL)
+
%:
- dh $@ --with autoreconf
+ dh $@
-override_dh_autoreconf:
- NOCONFIGURE=1 dh_autoreconf ./autogen.sh
+override_dh_auto_configure:
+ dh_auto_configure -- $(DEB_CMAKE_EXTRA_FLAGS)
override_dh_install:
find debian/tmp/usr/lib -name *.la -delete
@@ -19,5 +26,8 @@ override_dh_install:
override_dh_missing:
dh_missing --fail-missing
+override_dh_auto_test:
+ xvfb-run -a dh_auto_test --no-parallel
+
get-orig-source:
uscan --noconf --force-download --rename --download-current-version --destdir=..