aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLars Uebernickel <lars.uebernickel@canonical.com>2013-05-22 22:51:19 -0400
committerLars Uebernickel <lars.uebernickel@canonical.com>2013-05-22 22:51:19 -0400
commit3f3aa147ac8ee224f40d9c4e9800b4c5825fde59 (patch)
tree44d25da574f577ce6aa2f2e4d2b8641ad174d30d /src/Makefile.am
parent27f3661cfb2266ee87a552738e5c03774dc9ae68 (diff)
downloadayatana-ido-3f3aa147ac8ee224f40d9c4e9800b4c5825fde59.tar.gz
ayatana-ido-3f3aa147ac8ee224f40d9c4e9800b4c5825fde59.tar.bz2
ayatana-ido-3f3aa147ac8ee224f40d9c4e9800b4c5825fde59.zip
Add IdoMenuItemFactory
It's implementing the GtkMenuItemFactory extension point (only available in Ubuntu's version of gtk+). It doesn't create any menu items yet. The extension point must be registered before calling gtk_menu_new_from_model() with a menu model that references any of the custom menu items ido will provide. Registering means the type must exist in the type system. This patch adds an ido_init() which does that. Consumers of libido are required to call this function from now on.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e14efbf..d6012f1 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -18,7 +18,7 @@ sources_h = \
idoscalemenuitem.h \
idoswitchmenuitem.h \
idotimeline.h \
- libido.h
+ libido.h
EXTRA_DIST = \
ido.list \
@@ -59,6 +59,7 @@ AM_CFLAGS = \
$(COVERAGE_CFLAGS)
libido_0_1_la_SOURCES = \
+ libido.c \
idotypebuiltins.c \
idocalendarmenuitem.c \
idoentrymenuitem.c \
@@ -66,7 +67,8 @@ libido_0_1_la_SOURCES = \
idorange.c \
idoscalemenuitem.c \
idoswitchmenuitem.c \
- idotimeline.c
+ idotimeline.c \
+ idomenuitemfactory.c
libido3_0_1_la_SOURCES = $(libido_0_1_la_SOURCES)