aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-05-04 13:04:58 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-05-04 13:05:00 +0200
commit81db2957f86a86c96263dba63664d5d97f9937d5 (patch)
treea47883116399664bc8cccc0cd12a8125d5b28adb /tests/CMakeLists.txt
parentccd0834804ccb097dd2ee7d86618ff0cffd8389d (diff)
downloadayatana-ido-81db2957f86a86c96263dba63664d5d97f9937d5.tar.gz
ayatana-ido-81db2957f86a86c96263dba63664d5d97f9937d5.tar.bz2
ayatana-ido-81db2957f86a86c96263dba63664d5d97f9937d5.zip
CMakeLists.txt: Move coverage report generation macro into basefolder's CMakeLists.txt file.
With the previous approach, only coverage of the tests/ subfolder was reported (which always should be 100%). With this change, also coverage of the files in src/ is reported.
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt7
1 files changed, 0 insertions, 7 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 39cde1f..a31f789 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -23,10 +23,3 @@ target_link_libraries("gtest-menuitems"
)
add_test("gtest-menuitems" "gtest-menuitems")
add_dependencies("gtest-menuitems" ayatana-ido3-0.4)
-
-
-# coverage
-if (ENABLE_COVERAGE)
- find_package(CoverageReport)
- ENABLE_COVERAGE_REPORT(TARGETS "gtest-menuitems" TESTS "gtest-menuitems")
-endif()