aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-04-21 22:12:42 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-04-21 22:12:42 +0200
commitfcf633bdbc0b7d64fe1ea6005ab007f0db151c4e (patch)
tree359d2cc514826fb177cec39f6303d66649af56d4 /tests/Makefile.am
parent34e808d3b9a322db3908454944c69c1373572f66 (diff)
parent3adf9ec33ba1e5b6516dfb31f943da67926e86c7 (diff)
downloadayatana-ido-fcf633bdbc0b7d64fe1ea6005ab007f0db151c4e.tar.gz
ayatana-ido-fcf633bdbc0b7d64fe1ea6005ab007f0db151c4e.tar.bz2
ayatana-ido-fcf633bdbc0b7d64fe1ea6005ab007f0db151c4e.zip
Merge branch 'tari01-pr/switch-to-cmake'
Attributes GH PR #26: https://github.com/AyatanaIndicators/ayatana-ido/pull/26
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am50
1 files changed, 0 insertions, 50 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
deleted file mode 100644
index a4bc763..0000000
--- a/tests/Makefile.am
+++ /dev/null
@@ -1,50 +0,0 @@
-IDOLIB = $(top_builddir)/src/libayatana-ido3-0.1.la
-
-# xorg-gtest isn't buildable https://bugs.launchpad.net/ubuntu/+source/xorg-gtest/+bug/1388892
-# check_LIBRARIES = libgtest.a
-check_PROGRAMS =
-TESTS =
-
-AM_CPPFLAGS = \
- $(GTEST_CPPFLAGS) \
- -I${top_srcdir}/src
-
-#############################
-# Google Test base library
-#############################
-
-nodist_libgtest_a_SOURCES = \
- $(XORG_GTEST_SOURCE)/src/xorg-gtest-all.cpp \
- $(GTEST_SOURCE)/gtest-all.cc \
- $(XORG_GTEST_SOURCE)/src/xorg-gtest_main.cpp
-libgtest_a_CPPFLAGS = \
- $(XORG_GTEST_CPPFLAGS) \
- $(AM_CPPFLAGS) \
- $(GTEST_CPPFLAGS) -w
-libgtest_a_CXXFLAGS = \
- $(AM_CXXFLAGS)
-
-#############################
-# Menuitem tests
-#############################
-
-# xorg-gtest isn't buildable https://bugs.launchpad.net/ubuntu/+source/xorg-gtest/+bug/1388892
-# TESTS += gtest-menuitems
-# check_PROGRAMS += gtest-menuitems
-
-gtest_menuitems_SOURCES = \
- gtest-menuitems.cpp
-gtest_menuitems_CPPFLAGS = \
- $(GCC_CFLAGS) \
- $(GTK_CFLAGS) \
- $(MAINTAINER_CFLAGS) \
- $(AM_CPPFLAGS)
-gtest_menuitems_LDFLAGS = \
- -pthread
-gtest_menuitems_LDADD = \
- $(GTK_LIBS) \
- $(IDOLIB) \
- libgtest.a \
- -lX11 -lXi
-
-DISTCLEANFILES = Makefile.in